<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
  <meta charset="UTF-8" />
  <title>News briefs, week of March 13, 2019 - Quincy, Wash., news, sports and more</title>
      
  
  <link rel="stylesheet" href="http://qvpr.com/wp-content/themes/Lucid-Child/style.css" type="text/css" />
  <link rel="pingback" href="http://qvpr.com/xmlrpc.php" />

  <!--[if lt IE 9]>
    <script src="http://qvpr.com/wp-content/themes/Lucid/js/html5.js" type="text/javascript"></script>
  <![endif]-->

  <script type="text/javascript">
    document.documentElement.className = 'js';
  </script>

  
<!-- This site is optimized with the Yoast SEO plugin v9.7 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://qvpr.com/news-briefs-week-of-march-13-2019/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="News briefs, week of March 13, 2019 - Quincy, Wash., news, sports and more" />
<meta property="og:description" content="Bingo set for March 24 Quincy Valley Lions Club is planning Spring Bingo on Sunday, March 24, at the Quincy Valley Business &amp; Conference Center. Doors open at noon, and games start at 1 p.m. To play, the cost is $1 per sheet, or 30 games. Concessions available. A 50/50 raffle will support the Quincy &hellip;" />
<meta property="og:url" content="http://qvpr.com/news-briefs-week-of-march-13-2019/" />
<meta property="og:site_name" content="Quincy, Wash., news, sports and more" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Quincy-Valley-Post-Register/106999434873" />
<meta property="article:tag" content="briefs" />
<meta property="article:section" content="Community" />
<meta property="article:published_time" content="2019-03-13T23:33:32+00:00" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Quincy, Wash., news, sports and more &raquo; Feed" href="http://qvpr.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Quincy, Wash., news, sports and more &raquo; Comments Feed" href="http://qvpr.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/qvpr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Lucid Child v.1.0.0" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://qvpr.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-indie-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700%2C300&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans_condensed-css'  href='http://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-css-css'  href='http://qvpr.com/wp-content/themes/Lucid/epanel/shortcodes/css/shortcodes.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-responsive-css-css'  href='http://qvpr.com/wp-content/themes/Lucid/epanel/shortcodes/css/shortcodes_responsive.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='http://qvpr.com/wp-content/themes/Lucid/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.css?ver=1.3.4' type='text/css' media='screen' />
<link rel='stylesheet' id='et_page_templates-css'  href='http://qvpr.com/wp-content/themes/Lucid/epanel/page_templates/page_templates.css?ver=1.8' type='text/css' media='screen' />
<script type='text/javascript' src='http://qvpr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://qvpr.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://qvpr.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://qvpr.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://qvpr.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='http://qvpr.com/?p=12925' />
<link rel="alternate" type="application/json+oembed" href="http://qvpr.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fqvpr.com%2Fnews-briefs-week-of-march-13-2019%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://qvpr.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fqvpr.com%2Fnews-briefs-week-of-march-13-2019%2F&#038;format=xml" />

		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-62516085-1', 'auto');
			ga('send', 'pageview');
		</script>

	<!-- <meta name="NextGEN" version="3.1.7" /> -->
		<style>
				</style>
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" /><style>
		#featured .flex-direction-nav a:hover, #video-slider-section .flex-direction-nav a:hover { background-color: #ffb600; }
			#featured_section .active-slide .post-meta, #featured_section .switcher_hover .post-meta, .et_tab_link_hover .post-meta { background: #ffa500; }
			h3.main-title { background-color: #ffa500; -moz-box-shadow: inset 0 0 10px rgba(255,140,0,0.1); -webkit-box-shadow: inset 0 0 10px rgba(255,140,0,0.1); box-shadow: inset 0 0 10px rgba(255,140,0,0.1); border: 1px solid #ff8c00; }
				.widget li { background: url(http://qvpr.com/wp-content/themes/Lucid/images/widget-bullet.png) no-repeat 24px 24px; }
				.footer-widget li { background: url(http://qvpr.com/wp-content/themes/Lucid/images/widget-bullet.png) no-repeat 0 4px; }
				.et_mobile_menu li a { background-image: url(http://qvpr.com/wp-content/themes/Lucid/images/widget-bullet.png); }
		a { color: #ffa300; }
		.et_video_play { background-color: #ffa500; }
		#second-menu > ul > li > a:hover { background-color: #ffa500; }
		#second-menu ul ul li a:hover { background-color: #ffb122; }
		#second-menu ul.nav li ul { background: #ffa500; }
		#second-menu ul ul li a { border-top: 1px solid #ffb122; }
		</style><link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.10' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba-classic-2 .ssbp-text {
									display: none!important;
								}
								
								.ssba .fb-save
								{
								padding: 6px;
								line-height: 30px; }
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									font-family: Indie Flower;
									font-size: 20px;
									
									
								}
								

			   #ssba-bar-2 .ssbp-bar-list {
					max-width: 48px!important;;
			   }
			   #ssba-bar-2 .ssbp-bar-list li a {height: 48px!important; width: 48px!important; 
				}
				#ssba-bar-2 .ssbp-bar-list li a:hover {
				}
					
				#ssba-bar-2 .ssbp-bar-list li a::before {line-height: 48px!important;; font-size: 18px;}
				#ssba-bar-2 .ssbp-bar-list li a:hover::before {}
				#ssba-bar-2 .ssbp-bar-list li {
				margin: 0px 0!important;
				}@media only screen and ( max-width: 750px ) {
				#ssba-bar-2 {
				display: block;
				}
			}
@font-face {
				font-family: 'ssbp';
				src:url('http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1');
				src:url('http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),
					url('http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1') format('woff'),
					url('http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1') format('truetype'),
					url('http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');
				font-weight: normal;
				font-style: normal;

				/* Better Font Rendering =========== */
				-webkit-font-smoothing: antialiased;
				-moz-osx-font-smoothing: grayscale;
			}
</style>
</head>
<body class="post-template-default single single-post postid-12925 single-format-standard unknown et_includes_sidebar">
    <header id="main-header">
    <div class="container clearfix">
      <a href="#" class="mobile_nav closed">Pages Menu<span></span></a>      <nav id="top-menu">
        <ul id="menu-primary" class="nav"><li id="menu-item-5982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5982"><a href="http://qvpr.com/photo-gallery/">Photo Galleries</a></li>
<li id="menu-item-7725" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7725"><a href="http://qvpr.com/category/videos/">Videos</a></li>
<li id="menu-item-5983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5983"><a href="http://qvpr.com/special-sections/">Special Sections</a></li>
<li id="menu-item-5984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5984"><a href="http://qvpr.com/contact-us/">Contact Us</a></li>
<li id="menu-item-5985" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5985"><a href="http://qvpr.com/subscribe/">Get the paper</a></li>
</ul>      </nav>

      <div id="social-icons"><a href='https://www.facebook.com/pages/Quincy-Valley-PostRegister/106999434873' target='_blank'><img alt='Facebook' src='http://qvpr.com/wp-content/themes/Lucid-Child/images/facebook.png' /></a></div> <!-- end #social-icons -->
      <div id="search">
        <div id="search-form">
          <form method="get" id="searchform" action="http://qvpr.com//">
            <input type="text" value="Search This Site..." name="s" id="searchinput" />
            <input type="image" alt="Submit" src="http://qvpr.com/wp-content/themes/Lucid/images/search_btn.png" id="searchsubmit" />
          </form>
        </div> <!-- end #search-form -->
      </div> <!-- end #search -->
    </div> <!-- end .container -->
  </header> <!-- end #main-header -->

  
  <div class="container logo-header">
    <div id="logo-area">
      <a href="http://qvpr.com/">
                <img src="http://qvpr.com/wp-content/uploads/2017/04/QVPR-logo-small-2017-e1502495095371.png" alt="Quincy, Wash., news, sports and more" id="logo"/>
      </a>

          </div>
    <div class="slogan-area">
      <p>Community news for the Quincy, Washington, area since 1949</p>
    </div>
  </div> <!-- end .container -->

  <div id="secondary-menu">
    <div class="container">
      <a href="#" class="mobile_nav closed">Categories Menu<span></span></a>      <nav id="second-menu" class="clearfix">
        <ul id="menu-secondary" class="nav"><li id="menu-item-5974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5974"><a href="http://qvpr.com/category/news/">News</a></li>
<li id="menu-item-5976" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5976"><a href="http://qvpr.com/category/community/">Community</a></li>
<li id="menu-item-5977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5977"><a href="http://qvpr.com/category/businessagriculture/">Business/Agriculture</a></li>
<li id="menu-item-5978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5978"><a href="http://qvpr.com/category/opinion/">Opinion</a></li>
<li id="menu-item-5975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5975"><a href="http://qvpr.com/category/sports/">Sports</a></li>
<li id="menu-item-5979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5979"><a href="http://qvpr.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-6007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6007"><a href="http://qvpr.com/classifieds/">Classifieds:March 13, 2019</a></li>
<li id="menu-item-6273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6273"><a href="http://qvpr.com">home</a></li>
</ul>      </nav>
    </div> <!-- end .container -->
  </div> <!-- end #secondary-menu -->

  <div id="main-area">
    <div class="container">

                  <div class="entry ads-top">
                                    </div>
        

<div id="content-area" class="clearfix">
	<div id="left-area">
		<div id="breadcrumbs" class="clearfix">
          <a href="http://qvpr.com" class="breadcrumbs_home">Home</a> <span class="raquo">&raquo;</span>

                  <a href="http://qvpr.com/category/community/">Community</a> <span class="raquo">&raquo;</span> News briefs, week of March 13, 2019          </div> <!-- end #breadcrumbs -->		  
  <article id="post-12925" class="entry clearfix post-12925 post type-post status-publish format-standard hentry category-community tag-briefs">
    <p class="meta-info">Posted  on Mar 13, 2019</p>
        
        
    <div class="post_content clearfix">
      <h1 class="title">News briefs, week of March 13, 2019</h1>

      <p><strong>Bingo set for March 24</strong><br />
Quincy Valley Lions Club is planning Spring Bingo on Sunday, March 24, at the Quincy Valley Business &amp; Conference Center. Doors open at noon, and games start at 1 p.m. To play, the cost is $1 per sheet, or 30 games. Concessions available. A 50/50 raffle will support the Quincy Food Bank, and canned food will also be collected at the event for the food bank.</p>
<p><strong>Canal filling date changes</strong><br />
The Quincy-Columbia Basin Irrigation District will start filling the West Canal later than previously revised due to continued unforeseen winter weather conditions. The re-revised time is Saturday, March 23 at 9 p.m. Priming will continue on smaller canals and laterals through the first week of April, depending on the weather and the demand for water deliveries. Water users are urged to contact their respective watermaster headquarters to receive current information and schedules.</p>
<p><strong>Pheasants group plans banquet</strong><br />
The Columbia Basin Chapter of Pheasants Forever is having a banquet, fundraiser, membership drive and upland celebration on Saturday, March 30, at the Lakefront Hotel, 3000 W. Marina Drive, Moses Lake. Doors open at 5 p.m. with dinner served at 6:30 p.m. Tickets will include dinner and membership. For more information or tickets, contact Dick Price at dickprice@nctv.com, Sean Dougherty at CBPheasants@gmail.com, or Anne Tyson at aktysonemail@gmail.com. No tickets will be sold after March 23.</p>
<p><strong>Democrats set meeting in Quincy</strong><br />
The Grant County Democrats will meet in Quincy at 1 p.m., Saturday, March 16, in the club house at 1000 13th Ave. SW.</p>
<p><strong>Trout derby returns</strong><br />
The 9th annual Trout Fishing Derby at Burke Lake is scheduled for Saturday, March 23, weather permitting. Registration for adults is $30 and can be done online or at Quincy Hardware &amp; Lumber, Hooked on Toys in Wenatchee, or Sportsman’s Warehouse in East Wenatchee. For more information, go to www.quincyvalley.org.</p>
<p><strong>Senior Center: Serving pork roast</strong><br />
Last week’s game winners at Quincy Senior Center were: Rummikub – Pam Barrow and Ruth Minor.<br />
Wednesday’s meal at the center is chicken salad sandwich, pea bacon salad and oatmeal raisin cookie. Thursday’s is pork roast, roasted potatoes and vegetables, green salad, French rolls, and peanut butter sheet cake. Monday is Irish beef stew, bread sticks and Irish shortbread. Tuesday is dollar-size pancakes, scrambled eggs, bacon and fresh fruit, or soup from Monday. Wednesday is grilled ham and cheese sandwich, green salad and chocolate chip cookie.<br />
Dinner is served at 6 p.m. Prices are $7 for members and $8 for nonmembers.<br />
Lunch is served from 11:30 a.m. to 12:30 p.m. and is $5 for members, $6 for nonmembers.</p>
<p><strong>Dinner and auction return to Ephrata</strong><br />
The annual St Patrick’s Day Girls State and Boys State Dinner and Auction will be held at 5 p.m., Saturday, March 16, at the American Legion Post, 276 Eighth Ave. NW, Ephrata. The main meal will be served at 6 p.m. and consists of the traditional corned beef and cabbage, but ham will also be available. Members and guests are encouraged to get tickets early; they are available at the Post Home from 1 to 7 p.m., Monday through Saturday, and 9 a.m. to 6 p.m. on Sunday. The cost for this special event is $10 and $18 for couples. And because both The American Legion and American Legion Auxiliary are nonprofit veterans organizations, donations are tax deductible.<br />
In conjunction with Girls and Boys State Dinner/Auction, the American Legion will celebrate its 100th anniversary with special cake and ice cream.</p>
<p><strong>Library to host former history professor</strong><br />
Retired University of Washington professor Carlos Gil will give a bilingual program about immigration based on his own family’s experience over several decades at four North Central Regional Library branches in April.<br />
The program, “From Mexican to Mexican-American: A Family Immigration Story,” is scheduled for 6 p.m., April 3, at Quincy Public Library, and 5 p.m., April 2, at George Public Library.<br />
Gil is a UW emeritus professor of history and has toured the state lecturing on the “Hispanization” of the United States.</p>
<p><strong>Library hold regular activities</strong><br />
The Quincy Public Library, 208 Central Ave. S., 787-2359, offers programs at no charge.<br />
March 13, ATLAS: At the Library after School, 3:30-4:30 p.m.<br />
March 14, Preschool Story Time &amp; Craft, 10:30 a.m.<br />
March 14, Bilingual Story Time with Deb, 4 p.m.<br />
March 15, Northwest Sea Serpents &amp; Lake Monsters with David George Gordon. Also discussing unexplained creatures like Sasquatch. 4 p.m.<br />
March 16, STEM Kits, 1-3 p.m.; variety of games to play with.<br />
March 18, Minecraft, 3:30-5:30 p.m.; space is limited, and sign-up ahead of time is required.<br />
March 19, WeDo Lego Robotics, 3:30-5:15 p.m.; working with iPads and Legos.<br />
March 20, ATLAS At the Library after School, 3:30-4:30 p.m.<br />
March 21, No Story Time<br />
March 22, Fun with Board Games, 3:30-5 p.m.<br />
March 23, Keva Planks &amp; Mazes, 1-3 p.m.</p>
<p><strong>City prepares activities</strong><br />
The Quincy Recreation Department provides activities for a range of interests and ages. For information about these and other activities, call 787-3523, ext. 259.<br />
STEAM Night at the Activity Center will include building a leprechaun trap. Cardboard and other material will be supplied; Thursday, March 14, 5:30-7:30 p.m.<br />
Tiny Tot Basketball Camp, for children ages 3-6, will be held March 18-21, 5:30-6:15 p.m., at the Pioneer school gym.<br />
Micro Spring Soccer registration ends March 20. The season runs April 22 to May 22 for children born in the years 2012, 2013 and 2014. The cost is $30 per player.</p>
<p><strong>Historical society plans meeting</strong><br />
The Grant County Historical Society will hold its monthly meeting on Tuesday, March 12, at the Ephrata American Legion Post, 276 Eighth Ave. NW. The board meeting begins at 11 a.m., lunch is served at noon. Lunch will be served by the American Legion staff and the price is $7.50.<br />
Guests and members are invited to attend. To make lunch reservations, call 754-3334.</p>
<!-- Simple Share Buttons Adder (7.5.19) simplesharebuttons.com --><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><span class="ssba-share-text">Share This Story!</span><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://qvpr.com/news-briefs-week-of-march-13-2019/"  target="_blank" ><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" style="width: 35px;" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://qvpr.com/news-briefs-week-of-march-13-2019/&amp;text=News%20briefs%2C%20week%20of%20March%2013%2C%202019%20"  target=&quot;_blank&quot; ><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png" style="width: 35px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a><a data-site="email" class="ssba_email_share" href="mailto:?subject=News%20briefs,%20week%20of%20March%2013,%202019&#038;body=%20http://qvpr.com/news-briefs-week-of-march-13-2019/"><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/email.png" style="width: 35px;" title="Email" class="ssba ssba-img" alt="Email this to someone" /><div title="email" class="ssbp-text">email</div></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://qvpr.com/news-briefs-week-of-march-13-2019/"  target=&quot;_blank&quot; ><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png" style="width: 35px;" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /><div title="Linkedin" class="ssbp-text">Linkedin</div></a><a data-site="print" class="ssba_print ssba_share_link " href="#" onclick="window.print()"><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/print.png" style="width: 35px;" title="Print" class="ssba ssba-img" alt="Print this page" /><div title="Print" class="ssbp-text">Print</div></a><a data-site='pinterest' class='ssba_pinterest_share' href='javascript:void((function()%7Bvar%20e=document.createElement(&apos;script&apos;);e.setAttribute(&apos;type&apos;,&apos;text/javascript&apos;);e.setAttribute(&apos;charset&apos;,&apos;UTF-8&apos;);e.setAttribute(&apos;src&apos;,&apos;//assets.pinterest.com/js/pinmarklet.js?r=&apos;+Math.random()*99999999);document.body.appendChild(e)%7D)());'><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/pinterest.png" style="width: 35px;" title="Pinterest" class="ssba ssba-img" alt="Pin on Pinterest" /><div title="Pinterest" class="ssbp-text">Pinterest</div></a><a data-site="tumblr" class="ssba_tumblr_share" href="http://www.tumblr.com/share/link?url=http://qvpr.com/news-briefs-week-of-march-13-2019/"  target=&quot;_blank&quot; ><img src="http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/tumblr.png" style="width: 35px;" title="tumblr" class="ssba ssba-img" alt="Share on Tumblr" /><div title="Tumblr" class="ssbp-text">Tumblr</div></a></div></div>                </div>  <!-- end .post_content -->
  </article> <!-- end .entry -->

  
  
  	</div> <!-- end #left_area -->

		<div id="sidebar">
		<div id="media_image-4" class="widget widget_media_image"><h4 class="widgettitle"> </h4><img width="300" height="250" src="http://qvpr.com/wp-content/uploads/2018/08/ProvidenceFuneral-WebAd_300x250_sept-300x250.jpg" class="image wp-image-11397  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" /></div> <!-- end .widget --><div id="text-36" class="widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><p><a href="https://www.grantpud.org/getfiber" target="_blank" rel="noopener"><img src="http://qvpr.com/wp-content/uploads/2019/02/Grant-PUD-2019.01.31-HSN-Animated-300x250.gif" alt="Advertise on QVPR" /></a></p>
</div>
		</div> <!-- end .widget --><div id="text-13" class="widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><p><a href="http://www.localtel.com/?county=Grant" target="_blank" rel="noopener"><img src="http://qvpr.com/wp-content/uploads/2019/02/LocalTel_Web_ad_Simple_web.png" alt="Advertise on QVPR" /></a></p>
</div>
		</div> <!-- end .widget --><div id="text-33" class="widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><p><a href="http://www.wsdot.com/traffic/" target="_blank" rel="noopener"><img src="http://qvpr.com/wp-content/uploads/2017/11/winter-roads_300px-250px.jpg" alt="Advertise on QVPR" /></a></p>
</div>
		</div> <!-- end .widget -->		<div id="recent-posts-3" class="widget widget_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul>
											<li>
					<a href="http://qvpr.com/finalists-picked-qsd-director-job/">Finalists picked for QSD director job</a>
									</li>
											<li>
					<a href="http://qvpr.com/news-briefs-week-of-march-13-2019/">News briefs, week of March 13, 2019</a>
									</li>
											<li>
					<a href="http://qvpr.com/port-moves-ahead-on-industrial-property/">Port moves ahead on industrial property</a>
									</li>
					</ul>
		</div> <!-- end .widget -->	</div> <!-- end #sidebar -->
</div> 	<!-- end #content-area -->


    </div> <!-- end .container -->
  </div> <!-- end #main-area -->
  <footer id="main-footer">
      <div class="container">
      <div id="footer-widgets" class="clearfix">
              </div> <!-- end #footer-widgets -->
    </div> <!-- end .container -->

          <div id="bottom-advertisment">
        <div class="container">
                         <a href="https://www.facebook.com/quincywindermere/"><img src="http://qvpr.com/wp-content/uploads/2019/02/Windermere_728x90WEB_02112019.jpg" /></a>
                  </div> <!-- end .container -->
      </div>
      </footer> <!-- end #main-footer -->

  <div id="footer-bottom">
    <div class="container clearfix">
      <ul id="bottom-menu" class="bottom-nav"><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="http://qvpr.com/classifieds/">Classifieds:March 13, 2019</a></li>
<li id="menu-item-5995" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5995"><a href="http://qvpr.com/category/community/">Community</a></li>
<li id="menu-item-5996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5996"><a href="http://qvpr.com/category/sports/">Sports</a></li>
<li id="menu-item-5997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5997"><a href="http://qvpr.com/category/businessagriculture/">Business/Agriculture</a></li>
<li id="menu-item-5999" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5999"><a href="http://qvpr.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-5994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5994"><a href="http://qvpr.com/category/news/">News</a></li>
<li id="menu-item-223" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-223"><a target="_blank" href="http://www.wenatcheeworld.com/">The Wenatchee World</a></li>
<li id="menu-item-6272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6272"><a href="http://qvpr.com">home</a></li>
</ul>
      <p id="copyright" class="clear"><a href="http://qvpr.com/sitemap">Sitemap</a> | © 2019 All Rights Reserved</p>
    </div> <!-- end .container -->
  </div> <!-- end #footer-bottom -->

  <!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/qvpr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://qvpr.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.9.10'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/js/superfish.js?ver=1.0'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/js/jquery.flexslider-min.js?ver=1.0'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/js/jquery.fitvids.js?ver=1.0'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/js/custom.js?ver=1.0'></script>
<script type='text/javascript' src='http://qvpr.com/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/epanel/page_templates/js/fancybox/jquery.easing-1.3.pack.js?ver=1.3.4'></script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/epanel/page_templates/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=1.3.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_ptemplates_strings = {"captcha":"Captcha","fill":"Fill","field":"field","invalid":"Invalid email"};
var et_ptemplates_strings = {"captcha":"Captcha","fill":"Fill","field":"field","invalid":"Invalid email"};
/* ]]> */
</script>
<script type='text/javascript' src='http://qvpr.com/wp-content/themes/Lucid/epanel/page_templates/js/et-ptemplates-frontend.js?ver=1.1'></script>
<script type='text/javascript' src='http://qvpr.com/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
</body>
</html>
<!--Generated by Endurance Page Cache-->